Skip to end of metadata
Go to start of metadata

Throughout the years, new software packages and multiple versions of them have been deployed on our different computing platforms. In preparation for our future migration to Bologna - New Data Centre, we will be streamlining the number of software packages and their versions available, so the majority of the user base is on recent software stacks prior to our move.

To accomplish this, we will extend our annual cleanup cycle, removing in a first stage the modules for unused versions as well as those ones that were never set as default. After the session, you will not be able to load the modules affected.

Some of those modules are still actively used, so you are encouraged to check if any of the packages in the list below is used anywhere in your processing workload. If so, we recommend moving to the current default version for each of those software packages and libraries.

Note that the actual deployments and installations for those software packages are not going to be deleted at this point. This will be done at a later stage. 

If you are using any of the versions affected by this change outside the module system, we strongly recommend moving to the default version for that particular package before the second stage to avoid any future problems

If you have any concerns, please get in touch with our servicedesk@ecmwf.int.

When?

The session is scheduled for Wednesday 18 September 2019 at 10:00 UTC

Where?

The platforms affected are:

  • All clusters in our High Performance Computing Facility, mainly CCA and CCB
  • ECGATE
  • Linux Clusters
  • Linux Desktops

Packages to be retired

These are the packages and versions that will no longer be available through the module system on the different platforms:

PackageVersion
Magics2.20.2
Magics2.24.2
Magics2.26.2
Magics2.29.6
Magics2.30.0
Magics2.32.0
Magics2.32.2
Magics2.33.0
Magics2.35.0
Magics3.0.1
Magics3.0.2
Magics3.0.3
Magics3.2.1
Magics3.3.1
R3.0.1
R3.1.0
R3.1.3
R3.5.1
batch_utils1.0.1
batch_utils1.1
batch_utils1.2
batch_utils1.3
batch_utils1.5
cairo1.15.4
cdftools2.1
cdo1.6.0
cdo1.6.3
cdo1.7.0
cdo1.9.1
cdo1.9.2
cgal4.1
clang3.3
clang3.4
clang5.0.1
cmake2.8.11.2
cmake3.0.2
cmake3.1.2
cmake3.12.0
cmake3.3.2
cmake3.6.2
cmake3.7.1
cmor2.9.3
cmor3.2.2
cmor3.2.3
cmor3.3.3
codes_ui1.0.1
codes_ui1.1.0
codes_ui1.1.0-develop
codes_ui1.2.0-develop
codes_ui1.2.2
codes_ui1.2.3
comfies0.1
comfies0.3
comfies0.4
comfies0.5
comfies0.6
comfies1.0.2
comfies1.0.3
comfies1.0.4
darshan2.3.1-ecm1.2
darshan2.3.1-pre1
darshan2.3.1-single
doxygen1.8.5
ecaccess4.0.2t
ecbuild1.3.1
ecbuild1.3.2
ecbuild1.5.0
ecbuild1.6.0
ecbuild1.9.0
ecbuild2.1.0
ecbuild2.2.0
ecbuild2.3.0
ecbuild2.3.1
ecbuild2.5.0
ecbuild2.5.1
ecbuild2.6.1
ecbuild2.6.2
ecbuild2.7.0
ecbuild2.7.1
ecbuild2.7.2
ecbuild2.7.3
ecbuild2.8.1
ecbuild2.9.0
ecbuild2.9.2
ecbuild2.9.3
ecbuild2.9.4
eccodes0.16.0
eccodes2.0.0
eccodes2.1.0tmp
eccodes2.12.1
eccodes2.6.1
eccodes2.9.1
ecflow4.0.0
ecflow4.0.1
ecflow4.0.2
ecflow4.0.3
ecflow4.0.3.todel
ecflow4.0.4
ecflow4.0.5
ecflow4.0.6
ecflow4.0.7
ecflow4.0.8
ecflow4.0.8rc1
ecflow4.0.9
ecflow4.11.0
ecflow4.11.0-develop
ecflow4.12.0-develop
ecflow4.13.0
ecflow4.14.0
ecflow4.4.0
ecflow4.6.0
ecflow4.6.1
ecflow4.7.0
ecflow4.8.0
ecflowx4.6.0-develop
ecfs2.0.12
ecfs2.0.13rc1
ecfs2.0.13rc2
ecfs2.2.0
ecfs2.2.0-rc1
ecfs2.2.0-rc3
ecfs2.2.1-rc1
ecfs2.2.1-rc2
ecfs2.2.2-rc1
eckit0.12.0
eckit0.13.0
eckit0.23.0
eclib20131118
eclib20131205
ecmp1.1.0
ecpds4.0.0_2013110301
ecpds4.0.2_2014051101
ecpds4.0.2_2014271101
extrae3.4.3
extrae3.6.1
extrae3.6.1-single-mpi-lib
fcm2014.09.0
ferret7.2
ferret7.3-standalone
ferret7.4.2
fftw3.3.7
forge18.0.1
gcc8.2.0
gdal1.9.2
gdal2.0.2
git1.8.4
git2.6.1
grib_api1.12.0
grib_api1.12.1
grib_api1.12.3
grib_api1.12.3.OLD
grib_api1.12.3_dbg
grib_api1.13.0
grib_api1.13.1
grib_api1.19.0
grib_api1.21.0
grib_api1.22.0
grib_api1.23.0
grib_api1.23.1
grib_api1.25.0
grib_api1.26.0
hdf51.10.2
idl8.2
idl8.5.1
ifs-git-tools1.10.0
ifs-git-tools1.11.0
ifs-git-toolsdevelop
ifs-supportCY41R2.1.WORKS.8.3.1.login
ifs-supportCY41R2.NOTWORK.8.3.1
ifs-supportCY43R1.2
ifs-supportCY43R1.4
ifs-supportCY43R1.5
ifs-supportCY43R1.6
ifs-supportCY43R1.7
ifs-supportCY43R3.1
ifs-supportCY43R3.10
ifs-supportCY43R3.11
ifs-supportCY43R3.2
ifs-supportCY43R3.3
ifs-supportCY43R3.4
ifs-supportCY43R3.5
ifs-supportCY43R3.6
ifs-supportCY43R3.9
ifs-supportCY44R1.0
ifs-supportCY45
ifs-supportCY45R1.0
ifs-supportCY45R1.1
ifs-supportCY45R1.2
ifs-supportCY45R1.4
ifs-supportCY45R1.5
ifs-supportCY45R1.6
ifs-supportCY45R1.8
libemos392
libemos400
libemos407
libemos421
libemos422
libemos430
libemos431
libemos444
libemos445
libemos447
libemos448
libemos449
libemos450
libemos451
libemos453
libemos454
libemos456
libemos457
libemos459
libemos460
met3d1.3.0
met3d2017-11
metpy6.0.1
metpy6.0.3
metpy6.0.4
metview-python0.8.4
metview-python0.8.5dev
metview-python0.8.6
metview-python0.9.1
metview-python1.0.0
metview4.4.5
metview4.6.5
metview4.7.1
metview4.7.2
metview4.8.0
metview4.8.2
metview4.8.4
metview4.8.5
metview4.8.6
metview5.0.0-alpha-8
metview5.0.0-beta-1
metview5.0.1
metview5.0.2
metview5.1.0-develop
metview5.1.1
metview5.2.0
metview5.2.0-develop
metview5.2.1
metview5.2.2
metview5.2.4
metview5.3.0
metview5.3.0-develop
metview5.4.0
metview5.4.0-develop
metview5.5.0
metview5.5.0-develop
metview5.5.1
metview5.6.0-develop2
nag22
nag23
ncl6.1.2
ncl6.2.0
ncl6.3.0
nco4.0.8
nco4.3.1
nco4.6.1
odb1.0.6
odb_api0.10.0
odb_api0.10.5
odb_api0.10.5.4
odb_api0.11.3
odb_api0.12.0
odb_api0.17.2
odb_api0.17.4
odb_api0.17.5
openmpi1.10.3
openmpi1.10.4
openmpi3.0.1
panoply4.5.1
panoply4.7.0
pgen0.10.0.0
pgen0.10.0.1
pgen0.11.0.0
pgen0.11.0.1
pgen0.12.0.0
pgen0.12.0.1
pgen0.2.0.0
pgen0.6.0.0
pgen0.7.0.0
pgen0.7.0.1
pgen0.8.0.0
pgen0.9.0.0
pgen0.9.1.0
pgen0.9.2.0
pgen1.1.0.0
pgen1.1.1.0
pgen1.1.2.0
pgen1.1.3.0
pgen1.1.5.0
pgen1.1.5.1
pgen1.2.0.0
prepifs1.9.1-165
prepifs1.9.1-168
prepifs1.9.1-635
prepifs1.9.1-702
prepifs1.9.1-791
prepifs1.9.1-816
prepifs1.9.1-823
pyg2p2.0.1
python2.7.3-01
python2.7.6-01
python33.5.1-01
python33.6.1-01
quaver1.2.2.1
quaver1.2.4
rttov11.3
slurm14.03.7
subversion1.9.5
swig3.0.12
valgrind3.13.0
  • No labels

1 Comment

  1. Please do not get rid of doxygen. I am still using this one