Skip to end of metadata
Go to start of metadata

ECMWF is updating the default versions of its software packages and libraries used across all user platforms at the centre as part of the regular update cycle.

When?

The changes will take place on Wednesday 21 November 2018 11:00 - 11:30 UTC

What platforms are affected?

All user platforms at the centre will see their default additional software stack updated:

  • All clusters in our High Performance Computing Facility, mainly CCA and CCB
  • ECGATE
  • Linux Clusters
  • Linux Desktops

The next defaults are tagged as "nov18" in modules. After the session the previous defaults will be tagged as "old"

Table of contents

Highlights

A number of bug fixes and performance improvements have been introduced on the different versions to become default. Here are some of the most relevant new features:

  • Magics and Metview now use ecCodes to decode BUFR data.
  • New automatic contouring setting for Magics and Metview to match ECCHARTS styles.
  • BUFR decoding performance has been enhanced in ecCodes, and support for a number or new parameters in GRIB have been added.
  • ecflowUI, the new graphical client for ecFlow, comes with a number of improvements and bug fixes.

How to use the new versions for testing BEFORE the update

Users are strongly encouraged to test their software applications and data processing chain with the new versions of the various software packages before the date of the change to the default versions.

The new versions of the software packages can be selected by using the nov18 tag in modules. For example:

module swap metview/nov18

module load Magics/nov18

module load emos/nov18

module swap eccodes/nov18 

How to revert to the old versions in case of problems AFTER the update

Users that experience problems with the new default software packages after the update of 10 May will be able to revert to the old default versions. These can be selected with the commands:

module swap metview/old

module load Magics/old

module load emos/old

module swap eccodes/old 

Please let ECMWF know if you need to revert to the old version of any of the packages after the update of the defaults has taken place. 

Version changes

This table summarises the changes in the version of the different packages:

ecCodes is now the official ECMWF encoder and decoder for GRIB and BUFR formats. It supersedes GRIB-API, for the GRIB format, and EMOSLIB, for the BUFR. If you still use any of those, we encourage you to migrate to ecCodes.

PackageDefault versionRelease notesDownload page
BeforeAfter
EMOSLIB4.5.54.5.8History of EMOSLIB changesEMOSLIB Releases
GRIB-API1.26.11.27.0

Latest news

GRIB-API Releases

Please see the Release notes for full details of the changes implemented in each package.

Verify: discontinued

Verify (and metpy tagged as metpy/verify) will be discontinued. Please use quaver instead.

  • No labels

2 Comments

  1. Hi Xavier,

    After testing the nov18 tag, just a quick note: the points in the EMOSLIB version number are missing (457 instead of 4.5.7).

    Best regards,

    P. Narciso



    1. Hi Paulo,

      For historical reasons, the version name on the module system is kept without the dots, as the original versioning scheme of the package.

      Regards,

      Xavi